Subject: categories: Normal quotients of categories

From: Marco Grandis <[email-masked]>
Date: Tue, 17 Jan 2006 19:12:30 +0100

Following Andree Ehresmann's posting, and again in partial reply to
Jean Benabou, I would like to add some considerations on the quotient
of a category modulo a subcategory.

With best regards

Marco Grandis

------

1. Generalised quotients of categories.

     A very general notion of generalised congruence in a category -
also involving objects - can be found in a paper by Bednarczyk,
Borzyszkowski and Pawlowski [BBP].

     Here we will only consider a particular case, determined by the
maps which we want to become identities. More precisely, given a
category  X  and a set  A  of its arrows,  X/A  will denote the
quotient of  X  modulo the generalised congruence generated by
declaring every arrow in  A  to be equivalent to the identity of its
domain. (It exists, because the generalised congruences of a category
form a complete lattice, see [BBP].)

     The quotient  p: X -> X/A  is determined by the obvious
universal property:

- for every functor  f: X -> Y  which takes all the maps of  A  to
identities, there is a unique functor  f': X/A -> Y  such that f = f'p.

     It is interesting to note that  p  automatically satisfies a 2-
dimensional universal property, as one can easily deduce from the
fact that natural transformations can be viewed as functors  X ->
Y^2,  with values in the category of morphisms of  Y.

2. Kernels and normal quotients of categories.

     This particular case can be made clearer when viewed at the
light of general considerations on kernels and cokernels with respect
to an *assigned ideal* of "null" arrows, studied in [Gr] -
independently of the existence of a zero object. (For kernels with
respect to an ideal, see also Ehresmann [Eh] and Lavendhomme [La].)

     Take, in  Cat,  the ideal of *discrete* functors, i.e. those
functors which send every map to an identity; or, equivalently,
consider as *null* objects in  Cat  the discrete categories and say
that a functor is *null* if it factors through such a category (we
have thus a *closed* ideal, according to an obvious Galois connection
between set of maps and set of objects, see [Gr]).

     This ideal produces - by the usual universal properties
formulated *with respect to null functors* - a notion of kernels and
cokernels in  Cat.  Precisely, given a functor  f: X -> Y,  its
kernel is the wide subcategory of all morphisms of  X  which  f
sends to identities of  Y  (V(f),  in Benabou's notation), while its
cokernel is the quotient  Y -> Y/B,  produced by the set-theoretical
"arrow-image"  B  of  f.

     A normal subcategory  X'  of  X,  by definition, is a kernel of
some functor starting at  X,  or, equivalently, the kernel of the
cokernel of its embedding. It is necessarily a wide subcategory; but,
of course, there are wide subcategories which are not normal.

     Dually, a normal quotient  p: X -> X'  is the cokernel of some
functor with values in  X  (or, equivalently, the cokernel of its
kernel). A normal quotient is always surjective on objects (as it
follows easily using its factorisation through its full image), but -
of course - need not be surjective on maps.

     Now, the normal quotients of  X  are precisely those we have
considered in point 1. Indeed, given a set  A  of arrows of  X,  the
quotient  X -> X/A  is necessarily the cokernel of some functor  f
with values in  X  (eg, take the free category  A'  on the graph  A
and the resulting functor  f: A' -> X).

     The normal quotients of a category  X  form a *lattice*, anti-
isomorphic to the lattice of normal subcategories of  X,  via kernels
and cokernels.
     (More generally, this holds replacing  Cat  with any category
equipped with a closed ideal, and having kernels and cokernels wrt
it; see [Gr].)

3. References

[BBP] M.A. Bednarczyk - A.M. Borzyszkowski - W. Pawlowski,
Generalized congruences-epimorphisms in Cat, Theory Appl. Categ. 5
(1999), No. 11, 266-280.

[Eh] C. Ehresmann, Cohomologie a valeurs dans une categorie dominee,
Extraits du Colloque de Topologie, Bruxelles 1964, in: C. Ehresmann,
Oeuvres completes et commentees, Partie III-2, 531-590, Amiens 1980.
(See also the Comments in the same volume, p. 845-847.)
[Gr] M. Grandis, On the categorical foundations of homological and
homotopical algebra, Cah. Topol. Geom. Diff. Categ. 33 (1992), 135-175.

[La] R. Lavendhomme, Un plongement pleinement fidele de la categorie
des groupes, Bull. Soc. Math. Belgique, 17 (1965), 153-185.

---

From: jim stasheff <[email-masked]>
Date: Tue, 17 Jan 2006 17:30:36 -0500

[Note from moderator: reference was mentioned before, but is more complete
below]

Don't know if this got through already
as myu mail has been acting up:

There is also Drinfeld's

*math.KT/0210114* [abs <http://arxiv.org/abs/math.KT/0210114>, ps
<http://arxiv.org/ps/math.KT/0210114>, pdf
<http://arxiv.org/pdf/math.KT/0210114>, other
<http://arxiv.org/format/math.KT/0210114>] :
    Title: *DG quotients of DG categories*
    Authors: * Vladimir Drinfeld
    <http://arxiv.org/find/math/1/au:+Drinfeld_V/0/1/0/all/0/1>*
    Comments: 50 pages, Latex; some typographical errors corrected, some
    references added
    Subj-class: K-Theory and Homology; Algebraic Geometry; Algebraic
    Topology; Category Theory

jim