Subject: categories: Re: Name for a concept

From: Marco Grandis <[email-masked]>
Date: Fri, 2 Dec 2005 14:51:38 +0100

I think that such squares should be called "exact" or "semicartesian" (where cartesian square = pb).

They should be viewed as the natural self-dual generalisation of pullback and pushout. They appear whenever one studies categories of relations.

1. In an abelian category, I would prefer "exact", or "Hilton-exact".

Hilton considered such squares (for abelian categories), and proved that an equivalent condition is that this square (of proper morphisms) is "bicommutative" in the category of relations (i.e. it commutes and stays commutative when you reverse two "parallel" arrows - as relations).

Plainly:   bicartesian square  =>  pullback  =>  exact;  and dually.

REFERENCE:

P. Hilton, Correspondences and exact squares, in: Proc. Conf. on Categorical Algebra, La Jolla 1965, Springer, pp. 254-271.

2. Studying more general categories of relations, I considered "semicartesian squares"  (f,g, h,k),  defined - in any category - by the following self-dual property (after being commutative, of course):

Whenever  (f',g', h,k)  and  (f,g, h',k')  commute, also the external square  (f',g', h',k')  commutes

B

f'            f        h          h'

A'             A                D             D'

g'          g       k           k'

C

(add slanting arrows  f': A' --> B,  f: A --> B,   etc).

- Again: bicartesian square  =>  pullback  =>  semicartesian,  and dually.

- If pb's  and/or  po's exist, one can give a lot of equivalent properties; eg:

--  (f,g)  and the pb of  (h,k) have the same po (or the same commutative squares out of them).

- In an abelian category, semicartesian amounts to the previous notion.

- In Set, it characterises again those squares which are bicommutative in Rel.

REFERENCE:

M. Grandis, Symétrisations de categories et factorisations quaternaires, Atti Accad. Naz. Lincei Mem. Cl. Sci. Fis. Mat. Natur. 14 sez. 1 (1977), 133-207.

3. A 2-dimensional version of this property (actually a STRUCTURE on 2-cells), was introduced by Guitart, and called "H-exact", if I remember well (H for Hilton)

REFERENCES:

- R. Guitart, Carrés exacts et carrés deductifs, Diagrammes 6 (1981), G1-G17.

- R. Guitart and L. Van den Bril, Calcul des satellites et présentations des bimodules à l'aide des carrés exacts, Cahiers Topologie Géom. Différentielle 24 (1983), no. 3, 299-330.

(and some other papers by the same authors).

Best regards

Marco Grandis

---

From: "Ronald Brown" <[email-masked]>
Date: Fri, 2 Dec 2005 11:19:22 -0000

This kind of condition occurs in topology as a fibrant square - but where
all the maps are fibrations as is the map A ---> B x_D C . This can be
generalised to cubes. See a paper by R. Steiner on

`Resolutions of spaces by n-cubes of fibrations',  J. London Math. Soc.(2),
34, 169-176, 1986

used to build a complete (strict) algebraic model of homotopy n-types which
allows some computations.

This raises the spectre in algebra of

Resolutions of A by free  crossed n-cubes of A.

to give a more `nonabelian' homological algebra. Of course crossed n-cubes
of A should be equivalent to n-fold groupoids in A. This would presumably
bring in higher versions of nonabelian tensor products in A; a bibliography
of such a tensor, mainly for n=2, has 90 items.

This probably does not help to answer Mike's question on the name!

Ronnie
www.bangor.ac.uk/r.brown/nonabtens.html

----- Original Message -----
From: "Michael Barr" <[email-masked]>
To: "Categories list" <[email-masked]>
Sent: Thursday, December 01, 2005 1:48 AM
Subject: categories: Name for a concept

> Is there a standard name for a square
> A ----> B
> |       |
> |       |
> |       |
> v       v
> C ----> D
> in which the canonical map A ---> B x_D C is epic?  I had always called it
> a weak pullback, but Peter Freyd claims that that phrase is reserved for
> the case that it satisfies the existence, but not necessarily the
> uniqueness of the definition of pullback.  In fact, he claims it means
> that Hom(E,-) converts it to the kind of square I am talking about.
> What is interesting is that in an abelian category, it satisfies
> this condition iff it satisfies the dual condition iff the evident
> sequence A ---> B x C ---> D is exact.  Putting a zero at the left end
> characterizes a genuine pullback and at the other end a pushout.
>
> Michael
>
>
>

---

From: Eduardo Dubuc <[email-masked]>
Date: Mon, 5 Dec 2005 13:16:13 -0300 (ART)

> in which the canonical map A ---> B x_D C is epic?

These are called "quasi-pullbacks" by Joyal, and they form a class of
"open maps" in the category of squares. The pullbacks form the
corresponding class of etal maps. These two classes are essential for the
development of the theory (etal class and open class in the sense of
Joyal). There are published articles by Joyal and Moerdijk on the
subject.

---

From: Marco Grandis <[email-masked]>
Date: Wed, 7 Dec 2005 12:04:59 +0100

I do not know the original problem of M. Barr, may be he is really
interested in getting an epimorphism onto the pullback.

However - I apologise for insisting - I think that the important
notion for such squares should be a natural self-dual generalisation
of pullbacks and pushouts, based on commutative squares and nothing
else - so that, in particular, it cannot depend on the variation of
monos or epis one is interested in.

The one I have proposed in that old paper (under the name of
"semicartesian square") is of this kind:

- the square  (f,g; h,k)  commutes, and for every span  (f',g')
which commutes with the cospan  (h,k)  and every cospan  (h',k')
which commutes with the span  (f,g),  the new span and cospan form a
commutative square.

All this comes from the obvious Galois connection between sets of
spans and cospans (in an arbitrary category), derived from the
commutativity relation.

Explicitly, let us start with two fixed objects A, B.  Let  S  be the
set of spans from A to B:

x = (f: C -> A,  g: C -> B)    (for arbitrary C)

and  C  the set of cospans

y = (h: A -> D, k: B  -> D)   (for arbitrary D).

Take their set of parts,  PS  and  PC,  ordered by inclusion, and the
following (contravariant) Galois connection between them (X in PS, Y
in PC):

R(X) = set of cospans which commute with all the spans in X,
L(Y) = set of spans which commute with all the cospans in Y.

Now, a square  (x, y)  (span/cospan) commutes iff  {x} is contained
in  L({y})  iff  {y} is contained in R({x}).
A square  (x, y)  is "semicartesian" (or "exact") iff it satisfies
the stronger, equivalent conditions:

1.  R{x} = RL({y})
2.  L{y} = LR({x}).

Marco Grandis

-------------------------