Subject: categories: semi-categories

From: Francis Borceux <[email-masked]>
Date: Tue, 29 Nov 2005 14:55:58 +0100

There has been a long discussion on the list 
about "categories without identities", whatever 
you decide to call them. And the attention has 
been brought to axioms which could -- in this 
more general context -- replace the identity 
axiom.

I would like to focus on a very striking categorical aspect of this problem.

A (right) module M on a ring R with unit must satisfy the axiom m1=m
... but what about the case when R does not have a unit ?

Simply dropping the axiom m1=m leaves you with 
the unpleasant situation where you have two 
different notions of module, in the case where R 
has a unit.

Therefore people working in linear algebra have considered the axiom

      the scalar multiplication M@R ---> M is an isomorphism
      (@=tensor product sign)

which is equivalent to the axiom m1=m, when the 
ring has a unit ... but makes perfect sense when 
the ring does not have a unit. Such modules are 
generally called "Taylor regular".

A ring R with unit is simply a one-objet additive 
category and a right module M on R is simply an 
additive presheaf M ---> Ab (=the category of 
abelian groups).

A ring without unit is thus a "one-object 
additive category without identity", again 
whatever you decide to call this.

But what is the analogue of the axiom

      M@R ---> M is an isomorphism

when R is now an arbitrary small (enriched) 
"category without identities" and M is an 
arbitrary (enriched) presheaf on it ?

All of us know that to define a (co)limit, we do 
not need at all to start with an indexing 
category: an arbitrary graph with arbitrary 
commutativity conditions works perfectly well. In 
particular, a "category without identities" is 
all right. And the same holds in the enriched 
case, with (co)limits replaced by "weighted 
(co)limits".

Now every presheaf on a small category is 
canonically a colimit of representable ones ... 
but this result depends heavily on the existence 
of identities ! When you work with a presheaf M 
on a "category R without identities", you still 
have a canonical morphism

      canonical colimit of representables ---> R

and you can call M "Taylor regular" when this is 
an isomorphism. Again in the enriched case, 
"colimit" means "weighted colimit". This 
recaptures exactly the case of "Taylor regular 
modules", when working with Ab-enriched 
categories.

A sensible axiom to put on a "category R without 
identities" is the fact that the representable 
functors are "Taylor regular". (We should 
certainly call this something else than "Taylor 
regular", but let me keep this terminology in 
this message.)

And when R is a "Taylor regular category without identities", the construction

      presheaf on R |---> corresponding canonical colimit of representables

yields a reflection for the inclusion of Taylor 
regular presheaves in all presheaves.

A very striking property is the existence of a 
further (necessarily full and faithful) left 
adjoint to this reflection. This second inclusion 
provides in fact an equivalence with the full 
subcategory of those presheaves which satisfy the 
Yoneda isomorphism.

This yields thus a nice example of what Bill 
Lawvere calls the "unity of opposites": the two 
inclusions identify the category of Taylor 
regular presheaves with
* on one side, those presheaves which are colimits of representables;
* on the other side, those presheaves which satisfy the Yoneda lemma.
This underlines the pertinence of these "Taylor 
regular categories without identities".

To my knowledge, the best treatment of these 
questions is to be found in various papers by 
Marie-Anne Moens and by Isar Stubbe, in 
particular in the "Cahiers" and in "TAC".

And very interesting examples occur in functional 
analysis (the identity on a Hilbert space is a 
compact operator ... if and only if the space is 
finite dimensional) and also in the theory of 
quantales.

Francis Borceux

-- 
Francis BORCEUX
Département de Mathématique
Université Catholique de Louvain
2 chemin du Cyclotron
1348 Louvain-la-Neuve (Belgique)
tél. +32(0)10473170, fax. +32(0)10472530
[email-masked]

---

From: [email-masked]
Date: Wed, 30 Nov 2005 17:24:35 -0500

Perhaps it has not been sufficiently emphasized that semi-categories and
the like are not really "generalizations" of categories (though formally
they may appear so). Actually they present possibly-useful SPECIAL classes
of categories. That is because we represent one ultimately in an actual
large category (such as sets or abelian groups) and those representations
are indeed representations of a certain ordinary (V-) category, namely the
one freely generated by the given semicategory. The forgetful 2-functor
has a left adjoint, just as does the one from categories to directed
graphs etc. To be a value of such a left adjoint means that the large
category of representations may have special properties, for example it
may unite by a bicontinuous quotient p a pair of subcategories i, j whose
domains are identical but where i, j are themselves opposite in that they
are the respective adjoints to the same p. This is the kind of UIAO that
Francis refers to.

Is there a convincing example showing that it can be useful mathematically
to treat operator ideals (such as compact, nuclear, etc) as
semicategories?

I always believed that Jacobson invented rngs because algebraic practice
(not the dreaded categorists) had convinced him to grudgingly conclude
that after all ideals in rings are ideals but not subrings, whereas the
opposite view is not a convenience but a confusion which denies ideals
their dignity.

Bill Lawvere

Quoting Francis Borceux <[email-masked]>:

> A (right) module M on a ring R with unit must satisfy the axiom
> m1=3Dm
> Simply dropping the axiom m1=3Dm leaves you with
>       (@=3Dtensor product sign)
>
> which is equivalent to the axiom m1=3Dm, when the
> additive presheaf M ---> Ab (=3Dthe category of
> abelian groups).
>
> And when R is a "Taylor regular category without identities", the
> constructi> on
>
> D=E9partement de Math=E9matique
> Universit=E9 Catholique de Louvain
> 2 chemin du Cyclotron
> t=E9l. +32(0)10473170, fax. +32(0)10472530
> [email-masked]
>
>
>
>