Subject: categories: graphics

From: jim stasheff <[email-masked]>
Date: Sat, 21 Feb 2004 11:57:46 -0500

Thanks to all the suggestions for `flow chart' graphics.
I had first asked the alg top list and had no responses
whereas here I've received 4 or 5 suggestions

gastex,
dia (on Linux)
xy-pic
xfig
 "The LaTeX Graphics Companion",
Goossens, Rahtz, and Mittelbach
use the xy-pic and PSTricks packages
to draw flowcharts.

if anyone has used more than one and cares to comment,
I would appreciate that

as for example
Subject:
             Re: categories: graphics package
       Date:
             Sat, 21 Feb 2004 15:24:28 +0000 (GMT)
      From:
             Michael Abbott <[email-masked]>
         To:
             James Stasheff <[email-masked]>
 References:
             1

> Anyone have a recommendation for a software package that makes it easy
> to draw the equivalent of flow chart?
> with boxes, triangles, circles as junctions??

This can be done, with the dint of much pain, with XyPic directly in
LaTeX.  The layout tends to be perfect, but learning how to use the tool
for anything beyond the simplest diagrams is remarkably painful.

On the other hand, xfig produces very nice results with manual layout,
and
is really quite easy to use (though figuring out how to drop the
diagrams
into your LaTeX document has its surprises).

jim

---

From: David Yetter <[email-masked]>
Date: Sun, 22 Feb 2004 20:20:40 -0600

My favorite method is to draw figures in xfig, then export the result as
LaTeX picture code and edit the text to take advantage of LaTeX's
text processing capabilities, fonts and special symbols.

It would be quite suitable for flow chart graphics.

D. Yetter