Subject: categories: Structure Preserving: Definition?

From: <[email-masked]>
Date: Thu, 17 May 2001 15:57:33 -0500

Hello,
I've sent the following message to sci.math, but haven't
received a clear answer. I've also tried sci.math.research,
but the moderator bounced the posting. Possibly someone 
here can help?

Derek.
===============================================

I'm working through the following paper, trying to learn a bit
more about category theory:

Matrices, Monads and the Fast Fourier Transform
http://citeseer.nj.nec.com/jay93matrice.html

I this paper, the author explains vectors in categorical
notation:

"Vectors are distinguished from lists because their length
is given as part of their structure, represented by a morphism
(function) #: VA -> N."

What this means is that the morphism '#' will produce the
length of vector.

However, does this violate one of the requirements that a
morphism must preserve the structure of an object?  A vector
is a sequence of elements, and an integer is only a single
value. Does this mean that an integer has the same structure
as a vector?

Or does "structure preserving morphism" mean something
different?

Thanks,

Derek.

---

From: Charles Wells <[email-masked]>
Date: Fri, 18 May 2001 08:49:36 -0400

The function # should not have been referred to as a morphism.  It is an
operation.  Operations must be preserved by morphisms, but operations need not
be morphisms themselves.  (In fact a distributive law is a statement that some
operation is a morphism with respect to another operation.)

-Charles Wells

>but the moderator bounced the posting. Possibly someone 

Charles Wells, 
Emeritus Professor of Mathematics, Case Western Reserve University
Affiliate Scholar, Oberlin College
Send all mail to:
105 South Cedar St., Oberlin, Ohio 44074, USA.
email: [email-masked]. 
home phone: 440 774 1926.  
professional website: http://www.cwru.edu/artsci/math/wells/home.html
personal website: http://www.oberlin.net/~cwells/index.html
NE Ohio Sacred Harp website: http://www.oberlin.net/~cwells/sh.htm

---

From: Barry Jay <[email-masked]>
Date: Mon, 21 May 2001 12:21:02 +1000

Dear Derek,

since "Matrices, Monads and the Fast Fourier Transform" in
the early 90's I've written a couple of other papers on
semantics of datatypes. "A semantics for shape" considers
more general datatypes than just vectors. "Data categories"
is an attempt to embrace co-datatypes as well as
datatypes. These, and other papers about the implications
for computing, including the array programming language FISh
are available from my web-site

http://www-staff.it.uts.edu.au/~cbj

May I add that we are stabilising a prototype of FISh2 which
is altogether more expressive and simpler than FISh. We hope
to release it shortly. 

Now let me address your particular question.

you are concerned that the morphism #: VA -> N mapping a
vector of A's to its length does not appear to preserve any
structure, and so perhaps should not be a morphism at all.
There are two aspects to the answer. First, the existence of
this morphism is part of the definition of the object of
vectors. Given an arrow A -->I we define the corresponding
vectors by the pullback

VA ---> LA
|       | 
|       | 
NxI --> LI

where L is the list functor, and then # is defined by
composing VA -->NxI with the projection from NxI to N. If
the ambient category is Set then such pullbacks exist and
the function # is a well-defined function. The second point
is that # can be thought of as the upper part of an arrow
between arrows which maps a vector of A's to the
corresponding vector of 1's

VA ---> V1  isom   N
|       |          |
|       |          |
NxI --> Nx1 isom   N

I'd be happy to address any other questions you have
privately.

Yours,
Barry Jay

*************************************************************************
| Associate Professor C.Barry Jay,      Phone: (61 2) 9514 1814		|
| Associate Dean                        Fax:   (61 2) 9514 1807	        |
|   (Research, Policy and Planning)                                     | 
| University of Technology, Sydney,     e-mail: [email-masked]	|
| P.O. Box 123 Broadway, 2007,                                          |
| Australia.                     http://www-staff.it.uts.edu.au/~cbj	|
*************************************************************************