Subject: categories: co-exponential question

From: "Bill Halchin" <[email-masked]>
Date: Fri, 16 Jul 1999 12:55:48 PDT

This is actually a "dual" question.
Basically I want to do the dual of the construction
gives the notion of an exponential or map object.

Suppose we have a category C with sums. Then we build the
following category from C.

object:  T+X<-----Y

map: from T+X<-----Y  to T+X'<-------Y is a C map "alpha"  such
that we have the following diagram:

                   I-sub-T+alpha
         T+X---------------------------->T+X'
           ^                              ^
            \                            /
             \                          /
              \                        /
               \                      /
                \                    /
                 \                  /
                  \                /
                   \              /
                    \            /
                     \          /
                      \        /
                       \      /
                        \    /
                         \  /
                          \/
                          Y

   Then suppose there exists a C-object called Y**T such
that  T+Y**T<-------Y is the initial object of the category
just built above. What significance does Y**T have opposed
to the concept of an exponential???? If I did everything
correctly it (Y**T) should be the dual of T**Y.

Regards,

Bill Halchin

---

From: William James <[email-masked]>
Date: Tue, 20 Jul 1999 13:57:18 -0700

> correctly it (Y**T) should be the dual of T**Y.

Forgive my ignorance: is T+Y**T<----Y to be initial because
the usual construction for the exponential has the relevant
arrow as terminal? Can you suggest to me a reference for that
construction of exponentials?

As for significance: my own research into co-exponentials is
in terms of them as characteristic of lattices dual to
Heyting algebras. These dual-Heyting algebras work well
as algebras for a brand of paraconsistent logic (they have
a complement operator which has in general that an element
and its complement overlap). Alternatively, you can
think of co-exponentials as productive of the interesting
topological notions associated with closed sets, like boundary.

My feeling is that co-exponentials count as useful in more
interesting kinds of maths than turn up simply in those
categories dual to toposes.

William James

---

From: Paul Levy <[email-masked]>
Date: Tue, 20 Jul 1999 18:41:59 +0100 (BST)

I don't know if this is relevant to your question, but there is an example in
programming semantics where the dual of a cartesian closed
category has independent significance, due to Lafont, Streicher, Reus
and Hofmann.  (Some further work was done by Selinger.)  It is found in the following paper:
		  
@Article{StreicherReus:continuations,
  title =        "Classical logic, continutation semantics and abstract
                 machines",
  author =       "Th. Streicher and B. Reus",
  pages =        "543--572",
  journal =      "Journal of Functional Programming",
  month =        nov,
  year =         "1998",
  volume =       "8",
  number =       "6",
}

The construction is as follows.

Let C be a distributive
category, and let Ans (the "answer type") be an object in C, such that the exponential X -> Ans exists for
each object X.  Define two categories K and
N as follows. Both have the same objects as C.  In K, a morphism from
X to Y is a C-morphism from X x (Y -> Ans) to Ans.  In N, a morphism
from X to Y is a C-morphism from (X -> Ans) x Y to Ans. 

 Clearly these two
categories are dual.  Streicher and Reus' paper makes it clear that just as K can be
used to interpret a typed call-by-value language with control effects (which
was well-known), N can be used to interpret a typed call-by-name language
with control effects.  Like any call-by-name model, N is cartesian closed:

the product of X and Y in N is given by X+Y

the exponential from X to Y in N is given by (X -> Ans) x Y

K is certainly an important category, but I wouldn't say that the fact
that it has coexponentials is significant.  

Paul

===========================================================================
Paul Blain Levy, Department of Computer Science,
Queen Mary and Westfield College, LONDON E1 4NS
http://www.dcs.qmw.ac.uk/~pbl/
===========================================================================