Subject: categories: CATS Re: Categorical model for Floyd-Hoare logic?

From: "Roy L. Crole" <[email-masked]>
Date: Sat, 14 Feb 1998 18:30:29 GMT

There is some work by Paul Taylor on categorical models of while in
Theory and Formal Methods 1993, Springer Workshops in Computing, p302
on. 

Roy Crole

---

From: Barry Jay <[email-masked]>
Date: Mon, 16 Feb 1998 10:21:38 +1100 (EST)

A semantics of loops (and while-loops) where objects are types (not
predicates) can be found in

@InProceedings(Jay91d,
	Author={Jay, C.B.},
	Title={Fixpoint and loop constructions as colimits},
	Booktitle="Proceedings Summer Conference on Category Theory, 
	Como 1990",
	Editor="A.~Carboni, M.C.~Pedicchio and G.~Rosolini",
	Series=Lecture Notes in Mathematics,
	Volume=1488,
	Publisher=sv,
	Year=1991,
	Pages={187--192})

and their use to account for tail-recursion is in

@Article(Jay93a,
	Author={Jay, C.B.},
	Title={Tail recursion through universal invariants},
	Journal=Theoretcial Computer Science,
	Volume=115,
	Year=1993,
	Pages={151--189})

Barry Jay