Subject: categories: CTCS '99 FIRST CALL FOR PAPERS

From: "Martin Hofmann" <[email-masked]>
Date: Fri, 18 Dec 1998 16:07:10 GMT

CATEGORY THEORY AND COMPUTER SCIENCE (CTCS'99)
              10-12 SEPTEMBER 1999, EDINBURGH, SCOTLAND

                        FIRST CALL FOR PAPERS 

CTCS '99 is the 8th conference on Category Theory and Computer
Science. The purpose of the conference series is the advancement of
the foundations of computing using the tools of category theory. While
the emphasis is upon applications of category theory, it is recognized
that the area is highly interdisciplinary.

Typical topics of interest include but are not limited to
category-theoretic aspects of the following:

concurrent and distributed systems 
constructive mathematics
declarative programming and term rewriting 
domain theory and topology
linear logic 
models of computation 
program logics, data refinement, and specification 
programming language semantics 
type theory

Previous meetings have been held in Guildford (Surrey), Edinburgh,
Manchester, Paris, Amsterdam, Cambridge, and S. Margherita Ligure
(Genova).

PROGRAMME COMMITTEE

J. Adamek TU Braunschweig (Germany) 
N. Benton Microsoft Research, Cambridge (UK) 
R. Blute U. Ottawa (Canada)
T. Coquand Chalmers (Sweden) 
M. Escardo LFCS Edinburgh (UK)
M. Hasegawa Kyoto Univ. (Japan) 
M. Hofmann (Chair) LFCS Edinburgh (UK)
P. O'Hearn Queen Mary West (UK) 
D. Pavlovic Kestrel Institute (California) 
H. Reichel TU Dresden (Germany) 
G. Rosolini U. Genova (Italy) 
A. Scedrov U. Penn (Pennsylvania)

ORGANISING COMMITTEE

S. Abramsky LFCS Edinburgh (UK) 
P. Dybjer Chalmers U. (Sweden) 
E. Moggi U. Genova (Italy) 
A. Pitts U. Cambridge (UK)

SUBMISSION PROCEDURE

E-mail your contribution as a PostScript file to the programme chair
([email-masked]) to be received by 23 April 1999. Alternatively,
you can send 5 hardcopies by air mail to the program chair. Authors
with restricted copying facilities may also send a single
hardcopy. Please make sure mail submissions arrive before the deadline
(submissions postmarked 7 April 1999 will definitely be accepted). 

We would appreciate an informal notification of intention to submit 2
weeks prior to the deadline. It is anticipated to have at-conference
proceedings in the form of a Springer LNCS volume or similar. Details
about the publication forum will be given in the 2nd call for papers.

IMPORTANT DATES 

9 April 1999   Notification of intention to submit  
23 April 1999  Submission deadline 
4 June 1999    Notification of authors of accepted papers
2 July         Deadline for camera ready copies of accepted papers

ADDRESS FOR PAPER SUBMISSIONS

Martin Hofmann  ([email-masked])
Laboratory for Foundations of Computer Science  
Division of Informatics  
JCMB, King's Buildings  
Mayfield Road  
Edinburgh EH9 3JZ
UK

LOCAL ORGANISATION

Monika Lekuse  
Laboratory for Foundations of Computer Science  
Division of Informatics  
JCMB, King's Buildings  
Mayfield Road  
Edinburgh EH9 3JZ
UK

CONFERENCE E-ADDRESS
[email-masked]  

CONFERENCE HOMEPAGE
http://www.dcs.ed.ac.uk/home/ctcs99/
Watch this URL for later versions of this CFP and further information.

RELATED EVENT
2nd APPSEM workshop, 6-9 September 1999.

---

From: Anne Heyworth <[email-masked]>
Date: Tue, 22 Dec 1998 11:36:02 +0000 (GMT)

New PhD thesis to be found at:

http://xxx.lanl.gov/abs/math.CT/9812097

Summary of details:

Title: Applications of Rewriting Systems and Groebner Bases to Computing
       Kan Extensions and Identities Among Relations.
Authors: Anne Heyworth (University of Wales, Bangor).
Comments: PhD thesis, 104 pages, LaTeX2e. 
Report-no: University of Wales, Bangor preprint number 98-23.
Subj-class: Category Theory; Combinatorics.
MSC-class: 18-04 (Primary) 05-02; 20F05; 68Q42; 68Q40; 16S15 (Secondary).
\\
This thesis concentrates on the development and application of Groebner bases
methods to a range of combinatorial problems (involving groups, semigroups,
categories, category actions, algebras and K-categories).
Chapter Two contains the generalisation of rewriting and 
Knuth-Bendix procedures to Kan extensions.
Chapter Three shows that the standard Knuth-Bendix algorithm is 
step-for-step a special case of the Buchberger's algorithm for noncommutative
Groebner bases. 
The one-sided cases and higher dimensions are considered, and the relations
between these are made precise.
Chapter Four relates rewrite systems, Groebner bases and automata.
Reduction machines for rewrite systems are identified with standard 
output 
automata and the reduction machines devised for algebras are expressed as
Petri-nets.
Chapter Five introduces logged rewriting for group presentations. 
The completion of a logged rewriting system for a group  
determines a partial contracting homotopy which enables the computation 
of a set
of generators for the module of identities among relations using the 
covering 
groupoid methods devised by Brown and Razak Sallah. 
Reducing the resulting set of submodule generators is identified as a
Groebner basis problem.

--
Anne Heyworth.