Subject: categories: Reference?

From: Michael Barr <[email-masked]>
Date: Thu, 29 Oct 1998 14:00:03 -0500 (EST)

Can someone give me a reference for the fact that if the hom functor on a
category factors through commutative monoids then finite products are sums
and vice versa.  Also conversely.

Michael

---

From: "Dr. P.T. Johnstone" <[email-masked]>
Date: Fri, 30 Oct 1998 09:26:24 +0000 (GMT)

> and vice versa.  Also conversely.

Mac Lane (Categories for the Working Mathematician) does one direction
in Theorem 2 on page 190. (He assumes enrichment over abelian groups
rather than commutative monoids, but a glance at the proof shows that
the additive inverses are not used.) The converse is stated as Exercise
4 on page 194.

Peter Johnstone