Subject: Combining monads

From: categories <[email-masked]>
Date: Wed, 14 Jan 1998 15:10:01 -0400 (AST)

Date: Wed, 14 Jan 1998 16:21:51 +0000 (GMT)
From: Tom Leinster <[email-masked]>

Is the pullback of a monadic functor along a monadic functor
necessarily monadic?
Is the diagonal of the pullback square monadic?
Does this work if your restrict yourself to, say, finitary monadic
functors?

(E.g. it works for finitary monads on Set: the theory of sets with
both ring and lattice structure (not interacting in any particular
way) comes from a monad.)

Thanks,
Tom Leinster

---

From: categories <[email-masked]>
Date: Wed, 14 Jan 1998 19:38:11 -0400 (AST)

Date: Thu, 15 Jan 1998 09:58:50 +1100
From: Ross Street <[email-masked]>

>Is the pullback of a monadic functor along a monadic functor

No. And I seem to remember this was one of the main points of the thesis
(under Lawvere) of Michel Thie'baud. The thesis title was "Self-dual
structure-semantics & algebraic categories" (Dalhousie University, Halifax,
Nova Scotia, August 1971). Comonads (= cotriples) in Mod (= Bimod = Prof =
Dist) are the subject. Using these to define "algebraic", Michel obtained
stability under pullback.
--Ross

---

From: categories <[email-masked]>
Date: Thu, 15 Jan 1998 17:10:14 -0400 (AST)

Date: Thu, 15 Jan 1998 15:44:30 +1100 (EST)
From: Steve Lack <[email-masked]>

> Date: Wed, 14 Jan 1998 15:10:43 -0400 (AST)
> From: categories <[email-masked]>
> 

Let K be a complete and cocomplete category, and Mnd(K) the category
of monads on K and strict morphisms of monads. If T and S are monads
on K which preserve (alpha-)filtered colimits (for a regular cardinal
alpha), then 
	(i)the coproduct T+S exists in Mnd(K) 
	(ii)this coproduct is ``algebraic'', meaning that the diagonal
	    of the pullback square 
			       K^S
			        |
				|
				v
			  K^T-->K 
	    is the forgetful functor K^(T+S)-->K
	(iii)the projections K^(T+S)-->K^T and K^(T+S)-->K^S are
            monadic.
Much can be done without completeness, but the proofs become a bit harder.

See the paper
	G.M.Kelly, A unified treatment of transfinite constructions for
	free algebras, free monoids, colimits, associated sheaves, and so on,
	Bull. Austral. Math. Soc. 22(1980):1--83
for a survey of many such results.

In fact if K is locally finitely presentable then the category
Mnd_f(K) of finitary monads on K and strict morphisms of monads
is itself locally finitely presentable; for this see my paper
``On the monadicity of finitary monads'', to appear in JPAA, but
in the meantime available at
http://www.maths.usyd.edu.au:8000/res/Catecomb/Lack/1997-29.html.

Regards,

Steve.

---

From: categories <[email-masked]>
Date: Fri, 16 Jan 1998 14:20:24 -0400 (AST)

Date: Thu, 15 Jan 1998 23:21:27 +0100
From: Jan Juerjens <[email-masked]>
 
> way) comes from a monad.)

Hi Tom,

if I'm not mistaken, this reduces for full isomorphism-closed embeddings to the 
(finite) Intersection Problem (of full iso-closed subcategories) answered 
negatively by Trnkova, Adamek, Rosicky ("Topological reflections revisited", 
ProcAMS 108,3 (1990) p605; see also Tholen "Reflective Subcategories" TopAppl 27 
(1987) p201, Adamek, Rosicky "Intersections of reflective subcategories" ProcAMS 
103 (1988) p710).

Full iso-closed subcategories of locally lambda-presentable categories are 
reflective and closed under lambda-directed colimits iff they are 
lambda-orthogonal, so intersections of such subcategories are reflective 
(Adamek, Rosicky "Locally presentable and Accessible Categories" CUP 94).

Bye, Jan

[ + thanks again for the supervisions ... :-) ]